Ruby 1.9.3-p547 telah dirilis dan saat ini sedang memasuki fase pemeliharaan keamanan. Para pengembang/develover merilis Ruby 1.9.3 hanya jika terjadi sebuah insiden keamanan. Meskipun begitu, ada sebuah pengecualian. Sebagaimana dijelaskan para pengembang, develover melakukan pengembangan atau merilis versi terbaru jika regresi kritikal ditemukan.


Beberapa pengguna melaporkan masalah dalam lingkungan yang menggunakan versi lama dari OpenSSL, seperti Ubuntu 10.04 LTS. Ini merupakan regresi pada Ruby 1.9.3-p545. (Masalah yang sama juga terjadi pada Ruby 2.1.1 dan Ruby 2.0.0-p451 dan telah diperbaiki dengan Ruby 2.1.2 dan Ruby 2.0.0-p481.)

“Anda dapat Mengunjungi Bug #9592 untuk informasi lebih lanjut.

Jadi, penyedia memutuskan untuk merilis versi ini. Anda hanya harus melakukan Upgrade jika Anda terintegrasi/terpengaruh oleh masalah ini.


Rilis ini hanya berisi dua perubahan:

  • Sebuah fix untuk versi lama OpenSSL.
  • Sebuah perubahan kecil dari common.mk untuk manajemen penyedia (tidak mempengaruhi pengguna).  

    Jika anda ingin meng Upgrade klik Disini.Sumber: https://www.ruby-lang.org/id/

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *